annulla
Visualizzazione dei risultati per 
Cerca invece 
Intendevi dire: 

Non riesco a configurare l'hotspot con l'ultima procedura "per utenti esperti"

Grande
Grande

Ho effettuato tutti i passaggi per configurare l'hotspot con ADB.

In risposta al comando settings get global tether_dun_required visualizzo "null".

Nel momento però in cui inserisco il comando settings put global tether_dun_required 0 mi appare un segnale di errore: "Error while accessing settings provider

java.lang-SecurityException: Permission denial: writing to settings requires: android permission.WRITE_SECURE_SETTINGS", seguito da altre informazioni che non comprendo.

Come posso fare per risolvere il problema e impostare correttamente il parametro dun?

Grazie.

0 Kudos
5 RISPOSTE 5
Top - Livello 2
Top - Livello 2

Dalle impostazioni sviluppatore devi prima attivare la voce Debug USB (Impostazioni sicurezza)

Dopodiché potrai settare il tether_dun_required a 0.


Inviato dal mio Redmi Note 4 Global Version con l'offerta Ho. 50 giga da 9,99€
0 Kudos
Grande
Grande

Salve , anche io ho un ormai vecchio redmi 4a  ancora più che funzionante, almeno fino a che non sono passato ad HO. Funzionava benissimo come hotspot , ma adesso con ho-mobile no va.

Leggo su che c'è una guida per utenti esperti che purtroppo no riesco a trovare. Suggerimenti? Grazie.

0 Kudos
Capo ho.fficina
Capo ho.fficina

Ciao @Bebalevis, hai ricevuto un messaggio privato. Se hai bisogno di assistenza rispondimi così verifichiamo insieme per trovare una soluzione. Buona giornata

0 Kudos
Grande
Grande

Nel caso di dispositivo Meizu io ho risolto cosi'.

Credo valga per tutti i meizu, almeno il mio e' un MX5

 

Serve avere i diritti di root e avere applicazione su installata

Occorre installare adb sul pc

 

quindi:

 

da pc:

adb shell

 

Una volta ottenuta la shell eseguire:

 

su
mount -o rw,remount /system
cd /system
cp build.prop build.prop.bak
echo "net.tethering.noprovisioning=true" > /tmp/ho_patch
cat build.prop.bak /sdcard/ho_patch > build.prop
mount -o ro,remount /system

 

questa procedura aggiunge la righa che serve al file /system/build.prop

che essendo in area protetta richiede di settare come scrivibile la /system

 

consiglio di fare un check che ci sia la riga in fondo al file

e magari di farlo anche prima di eseguire i comandi precedenti per verificare che

non ci sia gia' per evitare di averla due volte.

cat /system/build.prop

 

poi serve riavviare

 

Nel mio caso questo non e' bastato e ho dovuto aggiungere nei setting ,dun dell APN:


tipo APN default,supl,dun

 

Cosi' facendo funziona

 

0 Kudos
Grande
Grande
Ciao, ho un m5 note con lo stesso problema, ho installato adb sul PC e fatto il collegamento, trovo il comando remount ma non riesco a proseguire, puoi darmi chiarimenti? Grazie
0 Kudos